Portkonflikt: MDaemon Connector for Outlook ist nur sporadisch erreichbar

In diesem Artikel zeigen wir Ihnen, wie Sie sporadischen Verbindungsproblemen beim MDaemon Email Server mit dem MDaemon Connector for Outlook auf den Grund gehen können. 

Problem: 

Trotz korrekter Client- und Server-Konfiguration ist der MDaemon Connector for Outlook für verschiedene Benutzer nur sporadisch oder gar nicht erreichbar. Eine Outlook-Profilverbindung kann nicht hergestellt werden. 


Ursache: 

Die Ursache solcher Probleme ist häufig, dass eine andere Software auf den gleichen Mail-Ports wie auch der MDaemon Email Server läuft, beispielsweise auf den IMAP-Ports 143 (unverschlüsselt) oder 993 (für eine verschlüsselte Verbindung). 
Indizien auf einen Portkonflikt liefert das Eventlog des Servers. Hier ein Auszug: 

"0.0.0.0:143 could not be initialized [EvNetwork]"

"0.0.0.0:993 could not be initialized [EvNetwork]"

Lösung: 

Prüfen Sie, ob andere Dienste auch auf den IMAP-Ports laufen, beispielsweise die E-Mail-Archivierungslösung MailStore Server. 

Dies sollten Sie idealerweise mit Hilfe von netstat oder Telnet prüfen. Mit Hilfe von netstat können Sie sich aktive TCP-Verbindungen und Ports, die auf dem Computer überwacht werden, anzeigen lassen.
Dafür öffnen Sie die cmd über Windows-Taste + r und geben danach "cmd" ein. 

Der passende Befehl lautet:

netstat -a

Weitere Informationen sowie eine Liste der einzelnen Parameter des netstat-Befehls finden Sie hier.

Eine Alternative zu netstat stellt Telnet dar. Mit Hilfe von Telnet können Client-Server-Verbindungen aufgebaut und damit der Zugriff, beispielsweise auf ein Server-System, hergestellt werden. Der Client startet den Verbindungsaufbau für eine Session mit dem Befehl "telnet", gefolgt von dem Computernamen oder der Ziel-IP-Adresse. 

Telnet ist ein Windows-Feature, das vorher noch installiert werden muss. Auf einem Windows Server-System kann der Telnet-Client mit dem folgenden PowerShell-Befehl installiert werden: 

Install-WindowsFeature -name Telnet-Client

Als nächstes öffnen Sie die cmd, gefolgt von dem Befehl "telnet". Hier geben Sie nun die IP-Adresse oder den FQDN des Servers ein; danach wählen Sie den entsprechenden Port aus (beispielsweise 143 für IMAP und 993 für IMAP-SSL). So können Sie die grundlegende Erreichbarkeit des Servers prüfen und feststellen, welcher Dienst antwortet. 


Antwort:

Tipp: Eine gutes Werkzeug dafür ist auch PuTTY.