MDaemon Connector for Outlook-Fehler 1316: "Das angegebene Konto ist bereits vorhanden"

Problem:
Nach einer Aktualisierung oder einer Installation/Deinstallation des MDaemon Email Server-Plug-ins für Outlook, dem MDaemon Connector for Outlook, erhalten Sie auf dem Client die Fehlermeldung "1316: Das angegebene Konto ist bereits vorhanden".

Ursache:
Vor der Installation wurde die MSI-Installationsdatei umbenannt. Durch das Umbenennen der Installationsdatei wurden fehlerhafte Werte in der Registrierung erzeugt.

Lösung:
Deinstallieren Sie den MDaemon Connector for Outlook auf den betroffenen Clients und installieren Sie ihn anschließend mit nicht-umbenannter MSI-Installationsdatei erneut. Hierfür müssen Sie bei der Registrierung zunächst die defekten Einträge reparieren. Dazu gehen Sie wie folgt vor:

  1. Öffnen Sie den Registry-Editor auf den betroffenen Clients.

  2. Navigieren Sie in den Schlüssel "Computer\HKEY_CLASSES_ROOT\Installer\Products\99F37496382DAAD4AACD309B5A1C7761".

  3. Ändern Sie den Eintrag "Transforms" auf "C:\WINDOWS\Installer\{69473F99-D283-4DAA-AADC-03B9A5C17716}\1031.MST".

  4. Navigieren Sie in den Sub-Schlüssel "Computer\HKEY_CLASSES_ROOT\Installer\Products\99F37496382DAAD4AACD309B5A1C7761\SourceList".

  5. Ändern Sie den Package Name entsprechend der .msi in der LastUsedSource.

  6. Kopieren Sie die Datei 1031.MST aus der intakten Installation in den Pfad "C:\WINDOWS\Installer\{69473F99-D283-4DAA-AADC-03B9A5C17716}".
Danach empfehlen wir, alle MDaemon Connector-Installationen zu deinstallieren und mit einer .MSI (im Originalnamen) wieder sauber zu installieren.
Alternativ dazu gibt es auch Third-Party-Tools, mit denen Sie fehlerhafte MSI-Installationen deinstallieren können.